You can use one of the browsers below to use clixifix®:

Internet Explorer/ Edge - latest version*

Google Chrome - latest version*

Mozilla Firefox - latest version*

Apple Safari - latest version*


*Earlier versions of the above, may still support clixifix® - please contact us for further information